1041. Be Unique (20)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None
#include<cstdio>
int a[100010],hashTable[100010] = {0};
int main(){
    int n;
    scanf("%d",&n);
    int i,k;
    for(i = 0; i < n; i++){
        scanf("%d",&a[i]);        
        hashTable[a[i]]++;
    }
    int ans = -1;
    for(i = 0; i < n; i++){
        if(hashTable[a[i]] == 1){
            
            ans = a[i];
            break;
        }
    } 
    if(ans == -1) printf("None");
    else printf("%d",ans);
    return 0;
}

 

posted @ 2018-03-25 20:43  王清河  阅读(106)  评论(0编辑  收藏  举报