1043. 输出PATest(20)

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“PATestPATest....”这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按PATest的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

redlesPayBestPATTopTeePHPereatitAPPT

输出样例:

PATestPATestPTetPTePePee
#include<cstdio>
#include<cstring>
int main(){
    char str[10010];
    int hashTable[10];
    char dic[6] = {'P','A','T','e','s','t'};
    gets(str);
    int len = strlen(str),sum = 0;
    for(int i = 0; i < len; i++){
        for(int j = 0; j < 6; j++){
            if(str[i] == dic[j]){
                hashTable[j]++;
                sum++;
            }
        }
    }
    while(sum > 0){
        for(int i = 0; i < 6; i++){
            if(hashTable[i] > 0){
                printf("%c",dic[i]);
                hashTable[i]--;
                sum--;
            } 
        } 
    }
    return 0;
}

 

posted @ 2018-03-25 19:55  王清河  阅读(85)  评论(0编辑  收藏  举报