1084. Broken Keyboard (20)

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or "_" (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:

7_This_is_a_test
_hs_s_a_es

Sample Output:

7TI
#include<cstdio>
#include<cstring>
int main(){
    char str1[85],str2[85];
    gets(str1);
    gets(str2);
    bool hashTable[128] = {false};   //ASCII码128位 
    int len1 = strlen(str1);
    int len2 = strlen(str2);
    for(int i = 0; i < len1; i++){
        char b,c;
        int j;
        for(j  = 0; j < len2; j++){
            b = str1[i];
            c = str2[j];
            if(b >= 'a' && b <= 'z') b -= 32;
            if(c >= 'a' && c <= 'z') c -= 32;
            if(b == c) break;
        }
        if(j == len2 && hashTable[b] == false){
            printf("%c",b);
            hashTable[b] = true;
        }
    }
    return 0;
}

 

posted @ 2018-03-25 13:36  王清河  阅读(106)  评论(0编辑  收藏  举报