1055. The World's Richest (25)

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=105) - the total number of people, and K (<=103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [-106, 106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (<= 100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line "Case #X:" where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output "None".

 

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None
复制代码
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 100010;
int Age[maxn] = {0};
struct person{
    int age,worth;
    char names[10];
}wealth[maxn],valid[maxn];
bool cmp(person a,person b){
    if(a.worth != b.worth) return a.worth > b.worth;
    else if(a.age != b.age) return a.age < b.age;
    else return strcmp(a.names,b.names) < 0;
}
int main(){
    int n,k;
    scanf("%d%d",&n,&k);
    for(int i = 0; i < n; i++){
        scanf("%s%d%d",wealth[i].names,&wealth[i].age,&wealth[i].worth);
    }
    sort(wealth,wealth+n,cmp);
    int validnum = 0;
    for(int i = 0; i < n; i++){
        if(Age[wealth[i].age] < 100){
            Age[wealth[i].age]++;
            valid[validnum++] = wealth[i];
        }
    }
    /*
for(int i = 0; i < validnum; i++){
        printf("%d: %s %d %d\n",i,valid[i].names,valid[i].age,valid[i].worth);
    }*/

    int m,Amin,Amax;
    for(int i = 1; i <= k; i++){
        scanf("%d%d%d",&m,&Amin,&Amax);
        printf("Case #%d:\n",i);
        int count = 0;
        for(int j = 0; j < validnum && count < m; j++){
          if(valid[j].age >= Amin && valid[j].age <= Amax){
              printf("%s %d %d\n",valid[j].names,valid[j].age,valid[j].worth);
            count++;
          }
        }
        if(count == 0) printf("None\n");
    }
    return 0;
}
复制代码

 

posted @   王清河  阅读(143)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示