1028. List Sorting (25)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90
复制代码
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct student{
    int id;
    char name[10];
    int grade;
}stu[100010];

bool cmp1(student a,student b){
    return a.id < b.id;
}
bool cmp2(student a,student b){
    int s = strcmp(a.name,b.name);
    if(s != 0) return s < 0;
    else return a.id < b.id;
}
bool cmp3(student a,student b){
    if(a.grade != b.grade) return a.grade < b.grade;
    else return a.id< b.id;
}
int main(){
    int n,c;
    scanf("%d%d",&n,&c);
    for(int i = 0; i < n; i++){
        scanf("%d %s %d",&stu[i].id,stu[i].name,&stu[i].grade);
    }
    if(c == 1) sort(stu,stu+n,cmp1);
    else if(c == 2) sort(stu,stu+n,cmp2);
    else if(c == 3) sort(stu,stu+n,cmp3);
    for(int i = 0; i < n; i++){
        printf("%06d %s %d\n",stu[i].id,stu[i].name,stu[i].grade);
    }
    return 0;
}
复制代码

 20191011

复制代码
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 100010;

struct Student
{
    int id;
    char name[10];
    int grade;
}stu[maxn];

bool cmpID(Student a,Student b)
{
    return a.id < b.id;
}

bool cmpName(Student a,Student b)
{
    int s = strcmp(a.name,b.name);
    if(s != 0) 
        return s < 0;
    else
        return a.id < b.id;
}

bool cmpGrade(Student a,Student b)
{
    if(a.grade != b.grade)
        return a.grade < b.grade;
    else
        return a.id < b.id;
}

int main()
{
    int n;
    int c;
    scanf("%d%d",&n,&c);
    for(int i = 0; i < n; i++)
    {
        scanf("%d %s %d",&stu[i].id,stu[i].name,&stu[i].grade); //加了\n会出错,不知道为何
        //scanf("%d",&stu[i].id);
        //getchar();
        //scanf("%s %d",stu[i].name,&stu[i].grade);
    }
    switch(c)
    {
        case 1:
            sort(stu,stu+n,cmpID);
            break;
        case  2:
            sort(stu,stu+n,cmpName);
            break;
        case  3:
            sort(stu,stu+n,cmpGrade);
            break;            
    }
    for(int i = 0; i < n; i++)
    {
        printf("%06d %s %d\n",stu[i].id,stu[i].name,stu[i].grade);
    }
    return 0;
}
复制代码

 

posted @   王清河  阅读(91)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示