1018. Public Bike Management (30)

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.


Figure 1

Figure 1 illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3, we have 2 different shortest paths:

1. PBMC -> S1 -> S3. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1 and then take 5 bikes to S3, so that both stations will be in perfect conditions.

2. PBMC -> S2 -> S3. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: Cmax (<= 100), always an even number, is the maximum capacity of each station; N (<= 500), the total number of stations; Sp, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci(i=1,...N) where each Ci is the current number of bikes at Si respectively. Then M lines follow, each contains 3 numbers: Si, Sj, and Tij which describe the time Tij taken to move betwen stations Si and Sj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0->S1->...->Sp. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of Sp is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0
复制代码
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn = 510;
const int INF = 1000000000;

int G[maxn][maxn],weight[maxn];//边权,点权
int cmax,n,sp,m;//最大停车数,停车点数,问题车点,道路数
int d[maxn];//最短距离
vector<int> pre[maxn];
vector<int>tempPath,path;
bool vis[maxn] = {false};

int minNeed = INF,minRemain = INF;

void Dijkstra(int s){
    fill(d,d+maxn,INF);
    d[s] = 0;
    for(int i = 0; i <= n; i++){     //=没加  是否要取到等号要看题目中的顶点几号到n还是n-1 
        int u= -1, min = INF;
        for(int j = 0; j <= n; j++){   //同上 
            if(vis[j] == false && d[j] < min){
                u = j;
                min = d[j];
            }
        }
        if(u == -1) return;
        vis[u] = true;         //错误处
        for(int v = 0; v <= n; v++){
            if(vis[v] == false && G[u][v] != INF){   //同上 
                if(d[v] > d[u] + G[u][v]){
                    d[v] = d[u] + G[u][v];
                    pre[v].clear();
                    pre[v].push_back(u);
                }else if(d[v] == d[u] + G[u][v]){   //错加点权 
                    pre[v].push_back(u);
                }
            }
        }
    }
}
void DFS(int v){
    if(v == 0){
        tempPath.push_back(v);
        int need = 0,remain = 0;
        for(int i = tempPath.size() - 1; i >=0; i--){
            int id = tempPath[i];
            if(weight[id] > 0){
                remain += weight[id];  
            }else{
                if(remain > abs(weight[id])){   //错用i 
                    remain -= abs(weight[id]);
                }else{
                    need += abs(weight[id]) - remain;  //少+ 
                    remain = 0;
                }
            }
        }
        if(need < minNeed){
            minNeed = need;
            minRemain = remain;
            path = tempPath;
        }else if(need == minNeed && remain < minRemain){
            minRemain = remain;
            path = tempPath;
        }
        tempPath.pop_back();
        return;
    }
    tempPath.push_back(v);
    for(int i = 0; i < pre[v].size(); i++){   //错用tempPath.size() 
         DFS(pre[v][i]);
    }
    tempPath.pop_back();
}

int main(){
    scanf("%d%d%d%d",&cmax,&n,&sp,&m);
    for(int i = 1; i <= n; i++){
        scanf("%d",&weight[i]);
        weight[i] -= cmax / 2;                //少[i] 
    }
    fill(G[0],G[0]+maxn*maxn,INF);
    int u,v;
    for(int i = 0; i < m; i++){
        scanf("%d%d",&u,&v);
        scanf("%d",&G[u][v]);
        G[v][u] = G[u][v];
    }
    Dijkstra(0);
    DFS(sp);
    printf("%d ",minNeed);
    for(int i = path.size() - 1; i >= 0; i--){
        printf("%d",path[i]);
        if(i > 0) printf("->");
    } 
    printf(" %d",minRemain);
    return 0;
} 
复制代码

 

posted @   王清河  阅读(373)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示