1076. Forwards on Weibo (30)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5
复制代码
#include<cstdio>
#include<queue>

#include<vector>
using namespace std;
const int maxn = 1010;
struct node{
    int id;
    int layer;
};
bool vis[maxn] = {false};
vector<node> Adj[maxn];

int BFS(int s,int L){
    int numForward = 0;
    queue<node> q;
    node start;
    start.id = s;
    start.layer = 0;
    q.push(start);
    vis[start.id] = true;
    while(!q.empty()){
        node top = q.front();
        q.pop();
        int u = top.id;
        for(int i = 0; i < Adj[u].size();i++){
             node next = Adj[u][i];
             next.layer = top.layer + 1;
                if(vis[next.id] == false&& next.layer <= L){
                q.push(next);
                vis[next.id] = true;
                numForward++;
            }
        }
    }
    return numForward;
}
int main(){
    int n,k;
    node user;
    scanf("%d%d",&n,&k);
    int numFollow,idForward;
    for(int i = 1; i <= n; i++){
        user.id= i;
        scanf("%d",&numFollow);
        for(int j = 0; j < numFollow; j++){
            scanf("%d",&idForward);
            Adj[idForward].push_back(user);
        }
    }
    int numQuery,s;
    scanf("%d",&numQuery);
    for(int i = 0; i < numQuery; i++){
        memset(vis,false,sizeof(vis));
        scanf("%d",&s);
        int numForward = BFS(s,k);
        printf("%d\n",numForward);
    }
    return 0;
}
复制代码

 

posted @   王清河  阅读(135)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示