1077. Kuchiguse (20)

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)
  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write "nai".

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai
#include<cstdio>
#include<cstring>
char s[100][260]; 
int minLen = 256;
int main(){
   int n,i,j;
   scanf("%d",&n);
   getchar();//记录换行符
   for(i = 0; i < n; i++){
        
     gets(s[i]);
     int len = strlen(s[i]);
     if(len < minLen) minLen = len;
     for(j = 0; j < len/2; j++){
         char temp = s[i][j];
         s[i][j] = s[i][len - j - 1];
         s[i][len - j - 1] = temp;
      } 
   }   
   int ans = 0;
   for(i = 0; i < minLen; i++){
        char c= s[0][i];
        bool same = true;
        for(j = 1; j < n; j++){
            if(c != s[j][i]){
                same = false;
                break;
            }
        }
        if(same) ans++;
        else break;
   }
   if(ans){
       for(i = ans -1; i >= 0; i--){
           printf("%c",s[0][i]);
       }
   }else{
       printf("nai");
   }
   
    return 0;
} 

 

#include<cstdio>
#include<cstring>
char s[100][260]; 
int minLen = 256;
int main(){
   int n,i,j;
   scanf("%d",&n);
   getchar();//记录换行符
   for(i = 0; i < n; i++){
     fgets(s[i],280,stdin);
     //gets(s[i]);
     int len = strlen(s[i]) - 1; //如果不-1 ,第二个测试点过不去。存疑 
     if(len < minLen) minLen = len;
     for(j = 0; j < len/2; j++){
         char temp = s[i][j];
         s[i][j] = s[i][len - j - 1];
         s[i][len - j - 1] = temp;
      } 
   }   
   int ans = 0;
   for(i = 0; i < minLen; i++){
        char c= s[0][i];
        bool same = true;
        for(j = 1; j < n; j++){
            if(c != s[j][i]){
                same = false;
                break;
            }
        }
        if(same) ans++;
        else break;
   }
   if(ans){
       for(i = ans -1; i >= 0; i--){
           printf("%c",s[0][i]);
       }
   }else{
       printf("nai");
   }
   
    return 0;
}
#include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
using namespace std;
string str[110];

string reverse(string a){
    int len = a.length();
    string res;
    for(int i = len - 1 ; i >= 0; i--){
        res.push_back(a[i]);
    }
    return res;
}

int main(){
    int n;
    scanf("%d",&n);
    getchar();
    int minlen = 230,ans = 0;
    for(int i = 0; i < n; i++){
        //fgets(str[i],270,stdin);
        //gets(str[i]);
        string temp;
        getline(cin,temp);
        int len = temp.length() - 1; //int len = temp.size();
        if(len < minlen) minlen = len;
        //getline(cin,str[i]);
        str[i] = reverse(temp);    
    }
    
//    for(int i = 0; i < minlen; i++){
//        putchar(str[0][i]);
//    }
    
    bool equal = true;
    int index = 0;
    while(1){
        for(int i = 1; i < n; i++){
            if(index > str[i].size() - 1|| index > str[0].size() - 1 || str[i][index] != str[0][index]){
                equal = false;
                break;
            }
        }
        if(!equal)
            break;
        index++;
    }
    if(index){
        for(int i = index - 1; i >= 0; i--){
            printf("%c",str[0][i]);
        }
    }else{
        printf("nai");
    }
    return 0;
}

 

posted @ 2018-03-13 16:05  王清河  阅读(133)  评论(0编辑  收藏  举报