1035. Password (20)

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

 

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However, if N is one, you must print "There is 1 account and no account is modified" instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified
复制代码
#include<cstdio>
#include<cstring>
const int maxn = 1010;
struct Node{
    char name[15],pw[15];
    bool ischange;
}T[maxn];

void modify(Node& t, int& cnt){
    int len = strlen(t.pw);
    for(int i = 0; i < len; i++){
        if(t.pw[i] == 'l'){
            t.pw[i] = 'L';
            t.ischange = true;
        }
        else if(t.pw[i] == '1'){
            t.pw[i] = '@';
            t.ischange = true;
        }
        else if(t.pw[i] == '0'){
            t.pw[i] = '%';
            t.ischange = true;
        }
        else if(t.pw[i] == 'O'){
            t.pw[i] = 'o';
            t.ischange = true;
        }
    }
    if(t.ischange) cnt++;
}
int main(){
    int n,i,cnt = 0;
    scanf("%d",&n);
    
    for(i = 0; i < n; i++){
        scanf("%s %s",T[i].name,T[i].pw);
        T[i].ischange = false;
    }
    for(i = 0; i < n; i++){
        modify(T[i],cnt);
    }
    if(cnt == 0){
        if(n == 1) printf("There is %d account and no account is modified",n);
        else printf("There are %d accounts and no account is modified",n);
    }else{
        printf("%d\n",cnt);
        for(i = 0; i < n; i++){
            if(T[i].ischange) printf("%s %s\n",T[i].name,T[i].pw);
        }
    }
    return 0;
} 
复制代码

 

posted @   王清河  阅读(124)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示