1005. Spell It Right (20)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five
复制代码
#include<cstdio>
#include<cstring>
int main(){
    char s[110];
    gets(s);  //gets()因为不安全已经被PAT禁用了
    int sum = 0, len = strlen(s);
    for(int i = 0; i < len; i++){
        sum += (s[i] - '0');
    }
    int ans[100],num = 0;
    do{
        ans[num++] = sum % 10;
        sum /= 10;
    }while(sum != 0);
    
    char word[10][10] = {
        "zero","one","two","three","four","five","six","seven","eight","nine" 
    };
    for(int j = num - 1; j >= 0; j--){
        printf("%s",word[ans[j]]);
        if(j > 0) printf(" ");
        else printf("\n");
        
    }
} 
复制代码

 

复制代码
// 0 要特判 
#include<iostream>
#include<string>
using namespace std;
char digit[11][10] = {
 "zero","one","two","three","four","five","six","seven","eight","nine"
};
int main(){
    string str;
    getline(cin,str);
    int sum,num[110],n = 0;
    for(int i = 0; i < str.length(); i++){
        sum += (str[i] - '0');
    }
    if(sum == 0) cout << "zero";
    else {
    while(sum > 0){
        num[n++] = sum % 10;
        sum /= 10;
    }
}
    for(int i = n - 1; i>= 0; i--){
        cout << digit[num[i]];
        if(i > 0) cout << " ";
    }
    return 0;
} 
复制代码

 

posted @   王清河  阅读(135)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示