1052. Linked List Sorting (25)

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (< 105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [-105, 105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1
复制代码
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 100010;
struct Node{
   int address,key,next;
   bool flag;
}node[maxn];

bool cmp(Node a,Node b){
    if(a.flag == false || b.flag == false){
        return a.flag > b.flag;
    }else{
        return a.key < b.key;
    }
}

int main(){
    int i;
    for(i = 0; i < maxn; i++){
        node[i].flag = false;
    }
    int begin,address;
    int n;
    scanf("%d%d",&n,&begin);
    for(i = 0; i < n; i++){
        scanf("%d",&address);
        scanf("%d%d",&node[address].key,&node[address].next);
        node[address].address = address;  //地址输出全为0时,address没有赋值 
    } 
    int p = begin,count = 0;
    while(p != -1){
        node[p].flag = true;
        count++;
        p = node[p].next;
    }
    if(count == 0) printf("0 -1");
    else{
        sort(node,node+maxn,cmp);
        printf("%d %05d\n",count,node[0].address);
        for(i = 0; i < count; i++){
          if(i < count - 1){
                  printf("%05d %d %05d\n",node[i].address,node[i].key,node[i+1].address);
             }else{
                     printf("%05d %d -1\n",node[i].address,node[i].key);
             }
        }
    }
    return 0;
}
复制代码

 

posted @   王清河  阅读(120)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示