1001. A+B Format (20)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

 

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991
复制代码
#include<cstdio>

int main(){
    int a,b,sum;
    scanf("%d%d",&a,&b);
    sum = a + b;
    if(sum < 0){
        printf("-");
        sum = -sum;
    }
    //if(sum == 0) printf("0");    //特判,或者用do while 循环 
    int ans[10], num = 0;
    do{
        ans[num++] = sum % 10;
        sum /= 10;
    }while(sum != 0);
    for(int i = num -1; i >= 0; i--){
        printf("%d",ans[i]);
        if(i > 0 && i % 3 == 0)printf(",");
    }

    return 0;
}
复制代码

 

posted @   王清河  阅读(111)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示