1073. Scientific Notation (20)

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9]"."[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input file contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros,

Sample Input 1:

+1.23400E-03

Sample Output 1:

0.00123400

Sample Input 2:

-1.2E+10

Sample Output 2:

-12000000000
复制代码
#include<cstdio>
#include<cstring>

int main(){
    char str[11000];
    gets(str);
    int pos = 0, len = strlen(str);
    int i;
    if(str[0] == '-') printf("-");
    while(str[pos] != 'E'){  //找到E的位置 
        pos++;
    }
    int exp = 0;
    for(i = pos + 2; i < len; i++){ //求出指数 
        exp = exp * 10 + (str[i] - '0');
    }
    if(exp == 0){
        for(i = 1; i < pos; i++){   //特判指数为零时,直接输出 
            printf("%c",str[i]);    
        }
    }
    if(str[pos + 1] == '-') { //如果指数为负 
        printf("0.");
        for(i = 0; i < exp - 1; i++){
            printf("0");
        }
        printf("%c",str[1]);
        for(i = 3; i < pos; i++){
            printf("%c",str[i]);
        }
    }else{
        for(i = 1; i < pos; i++){
            
            if(str[i] == '.') continue;
            printf("%c",str[i]);
            if(i == exp + 2 && exp !=  pos - 3){ //pos-3代表这个数字有效部分长度,exp表示指数。如果指数大于pos-3,意味着不用输出小数点。
                printf(".");
            }
        }
        for(i = 0; i < exp - (pos - 3); i++){
            printf("0");
        }
    } 
    
    return 0;
}
复制代码

 

posted @   王清河  阅读(126)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示