1061. Dating (20)

Sherlock Holmes received a note with some strange strings: "Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm". It took him only a minute to figure out that those strange strings are actually referring to the coded time "Thursday 14:04" -- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter 'D', representing the 4th day in a week; the second common character is the 5th capital letter 'E', representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is 's' at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:

Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:

For each test case, print the decoded time in one line, in the format "DAY HH:MM", where "DAY" is a 3-character abbreviation for the days in a week -- that is, "MON" for Monday, "TUE" for Tuesday, "WED" for Wednesday, "THU" for Thursday, "FRI" for Friday, "SAT" for Saturday, and "SUN" for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:

3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm

Sample Output:

THU 14:04
复制代码
#include<cstdio>
#include<cstring>
char week[10][5] = {
    "MON","TUE","WED","THU","FRI","SAT","SUN"
};
int main(){
    char str1[65],str2[65],str3[65],str4[65];
    gets(str1);
    gets(str2);
    gets(str3);
    gets(str4);
    int len1 = strlen(str1);
    int len2 = strlen(str2);
    int len3 = strlen(str3);
    int len4 = strlen(str4);
    
    int i;
    for(i = 0; i < len1 && i < len2; i++){
        if(str1[i] == str2[i] && str1[i] >= 'A' && str1[i] <= 'G'){
            printf("%s ",week[str1[i] - 'A']);
            break;
        }
    }
    for(i++; i < len1 && i < len2; i++){
        if(str1[i] == str2[i]){
            if(str1[i] >= '0' && str1[i] <= '9'){
                printf("%02d",str1[i] - '0');
                break;
            }else if(str1[i] >= 'A' && str1[i] <='N'){
                printf("%d",str1[i] - 'A' + 10);
                break;
            }
        }
    }
    for(i = 0; i < len3 && i < len4; i++){
      if(str3[i] == str4[i]){
             if((str3[i] >= 'A' && str3[i] <= 'Z') || (str3[i] >= 'a' && str4[i] <= 'z')){
                 printf(":%02d\n",i);
                 break;
             }
        }
    }
    return 0;
}
复制代码

 

posted @   王清河  阅读(109)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示