1031. Hello World for U (20)

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

 

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor
复制代码
#include<cstdio>
#include<cstring>
int main(){
    char str[80];
    gets(str);
    int N = strlen(str); 
    // 最重要的就是找n1,n2,n3的数量关系。 
    int n1 =(N+2)/3,n3 = n1, n2 = N - n1 - n3 +2; //n1 不是 N/3,n2还要加上一个2 
    for(int i = 0; i < n1-1; i++){
        printf("%c",str[i]);
        for(int j = 1; j < n2-1; j++){
            printf(" ");
        }
       printf("%c\n",str[N - i -1]);
    }
    for(int k = 0; k < n2; k++){
        printf("%c",str[n1+k-1]);
        if(k == n2-1)printf("\n");
    }
    return 0;
}
复制代码

 

posted @   王清河  阅读(115)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示