1036. Boys vs Girls (25)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

 

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA
复制代码
#include<cstdio>
#include<cstring> 
struct student{
    char name[15];
    char id[15];
    int score;
}M,F,temp;
void init(){
    M.score = 101;
    F.score = -1;
}
int main(){
    init();
    int n;
    char gender;
    scanf("%d",&n);
    
    for(int i = 0; i < n; i++){
        scanf("%s %c %s %d",temp.name,&gender,temp.id,&temp.score);
        if(gender == 'M' && M.score > temp.score) M = temp; // 男孩分数低,设置最高,大于输入,赋值 
        else if(gender == 'F' && F.score < temp.score) F = temp; 
    }
    if(F.score == -1)printf("Absent\n");
    else printf("%s %s\n",F.name,F.id);
    if(M.score == 101) printf("Absent\n");
    else printf("%s %s\n",M.name,M.id);
    if(F.score == -1 || M.score == 101) printf("NA\n");
    else printf("%d\n",F.score - M.score);
    
    return 0;
}
复制代码

 

posted @   王清河  阅读(130)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示