1030. Travel Plan (30)

 

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Inpzut Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output

0 2 3 3 40
复制代码
//Dijkstra
#include<cstdio> #include<cstring> #include<algorithm> using namespace std; const int maxn = 510; const int INF = 1000000000; //城市数,道路数,起点,终点 //距离矩阵,花费矩阵 //最短距离,花销最小,前驱数组:记录走过的最短距离路径 int n,m,st,ed; int G[maxn][maxn],cost[maxn][maxn]; int d[maxn],c[maxn],pre[maxn]; bool vis[maxn] = {false}; void Dijkstra(int s){ fill(d,d+maxn,INF); fill(c,c+maxn,INF); d[s] = 0; c[s] = 0; for(int i = 0; i < n; i++){ int u = -1, MIN = INF; for(int j = 0; j < n; j++){ if(vis[j] == false && d[j] < MIN){ u = j; MIN = d[j]; } } if(u == -1) return; vis[u] = true; for(int v = 0; v < n; v++){ if(vis[v] == false && G[u][v] != INF){ if(d[v] > d[u] + G[u][v]){ d[v] = d[u] + G[u][v]; c[v] = c[u] + cost[u][v]; pre[v] = u; }else if(d[v] == d[u] + G[u][v]){ if(c[v] > c[u] + cost[u][v]){ c[v] = c[u] + cost[u][v]; pre[v] = u; } } } } } } void DFS(int v){ if(v == st){ printf("%d ",v); //dijkstra 深度遍历输出路径输出的是v,而不是pre【v】 return; } DFS(pre[v]); printf("%d ",v); } int main(){ scanf("%d%d%d%d",&n,&m,&st,&ed); int u,v; fill(G[0],G[0]+maxn*maxn,INF); for(int i = 0; i < m; i++){ scanf("%d%d",&u,&v); scanf("%d%d",&G[u][v],&cost[u][v]); G[v][u] = G[u][v]; cost[v][u] = cost[u][v]; } Dijkstra(st); DFS(ed); printf("%d %d\n",d[ed],c[ed]); return 0; }
复制代码

 

复制代码
#include<cstdio>
#include<algorithm> //fill 和 memset赋值 
#include<vector>
using namespace std;  //这个不能少 

const int maxv = 510;
const int INF = 1000000000;

int n,m,st,ed;// 城市数,道路数,起点,终点 
int G[maxv][maxv],cost[maxv][maxv]; //距离矩阵,花费矩阵 
int d[maxv],minCost = INF;//记录最短路径,最短路径(初始值最大)  
vector<int> pre[maxv]; //记录最短路径前驱 
vector<int> path,tempPath; //临时路径,最优路径 
bool vis[maxv] = {false}; 

void Dijkstra(int s){
    fill(d,d+maxv,INF);
    d[s] = 0;
    for(int i = 0; i < n; i++){
        int u = -1, min = INF;
        for(int j = 0; j < n; j++){
            if(vis[j] == false && d[j] < min){
                u = j;
                min = d[j];
            }
        }
        if(u == -1) return;
        vis[u] = true;
        for(int v = 0; v < n; v++){
            if(vis[v] == false && G[u][v] != INF){
                if(d[v] > d[u] + G[u][v]){
                    d[v] = d[u] + G[u][v];
                    pre[v].clear();
                    pre[v].push_back(u);
                }else if(d[v] = d[u] + G[u][v]){
                    pre[v].push_back(u);
                }
            }
        }
    }
}

void DFS(int v){
    if(v == st){ //判断其相等 
        tempPath.push_back(v);  //加入到临时路径来比较 
        int tempCost = 0;
        for(int i = tempPath.size()-1; i > 0; i--){
            int id = tempPath[i],idNext = tempPath[i-1];
            tempCost += cost[id][idNext];
        }
        if(tempCost < minCost){
            minCost = tempCost;
            path = tempPath;
        }
        tempPath.pop_back();
        return;
    }
    tempPath.push_back(v);
    for(int i = 0; i < pre[v].size(); i++){
        DFS(pre[v][i]);
    }
    tempPath.pop_back();
}

int main(){
    scanf("%d%d%d%d",&n,&m,&st,&ed);
    fill(G[0],G[0]+maxv*maxv,INF);
    fill(cost[0],cost[0]+maxv*maxv,INF);
    int u,v;
    for(int i = 0; i < m; i++){
        scanf("%d%d",&u,&v);
        scanf("%d%d",&G[u][v],&cost[u][v]);
        G[v][u] = G[u][v];
        cost[v][u] = cost[u][v];
    }
    Dijkstra(st);
    DFS(ed);
    for( i = path.size()-1; i >= 0; i--){  //c-free里这里i不用再次定义,在PAT中这里还需要加int 
        printf("%d ",path[i]);           //最优路径顺序已经存储在path里
    }
    printf("%d %d",d[ed],minCost);  //minCost是变量
    return 0;
}
复制代码

 

posted @   王清河  阅读(271)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示