1065. A+B and C (64bit) (20)

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false
复制代码
//long long 有效位为[-2^63,2^63,),如果a,b取到临界点,会出现溢出。
// A+B最大为 2^64-2(左开右闭),(2^64-2)%2^63=-2,long long的正溢出的范围为[-2^63,-2]
// 所以A>0,B>0,A+B<0时,为正溢出,结果为true。
//相同long long负溢出范围为[0,2^63],当A<0,B<0,A+B>=0时结果为负 
#include<cstdio>
int main(){
    int k,Tcase = 1; //变量不能用case
    scanf("%d",&k);
    for(int i = 0; i < k; i++){
        long long a,b,c;
        scanf("%lld%lld%lld",&a,&b,&c);
        long long res;
        res = a + b;
        bool flag;
        if(a < 0 && b < 0 && res >= 0) flag = false;   // 负溢出时等号可以取到
        else if(a > 0 && b > 0 && res < 0) flag = true;  //正溢出为true,负溢出为false
        else if(res > c) flag = true;
        else flag = false;
        if(flag == true) printf("Case #%d: true\n",Tcase++);
        else printf("Case #%d: false\n",Tcase++);
    }
    return 0;
}
复制代码

 

posted @   王清河  阅读(98)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示