1065. A+B and C (64bit) (20)

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false
//long long 有效位为[-2^63,2^63,),如果a,b取到临界点,会出现溢出。
// A+B最大为 2^64-2(左开右闭),(2^64-2)%2^63=-2,long long的正溢出的范围为[-2^63,-2]
// 所以A>0,B>0,A+B<0时,为正溢出,结果为true。
//相同long long负溢出范围为[0,2^63],当A<0,B<0,A+B>=0时结果为负 
#include<cstdio>
int main(){
    int k,Tcase = 1; //变量不能用case
    scanf("%d",&k);
    for(int i = 0; i < k; i++){
        long long a,b,c;
        scanf("%lld%lld%lld",&a,&b,&c);
        long long res;
        res = a + b;
        bool flag;
        if(a < 0 && b < 0 && res >= 0) flag = false;   // 负溢出时等号可以取到
        else if(a > 0 && b > 0 && res < 0) flag = true;  //正溢出为true,负溢出为false
        else if(res > c) flag = true;
        else flag = false;
        if(flag == true) printf("Case #%d: true\n",Tcase++);
        else printf("Case #%d: false\n",Tcase++);
    }
    return 0;
}

 

posted @ 2018-03-08 08:08  王清河  阅读(96)  评论(0编辑  收藏  举报