1046. Shortest Distance (20)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7
#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn = 100010;
int dis[maxn],A[maxn];

int main(){
  int sum = 0,n,left,right;
  scanf("%d",&n);
  for(int i = 1; i <= n; i++){
      scanf("%d",&A[i]);
      sum += A[i];
      dis[i] = sum;  // dis代表从1个顶点到第i个顶点的距离 
  }
  int m;
  scanf("%d",&m);
  for(int i = 0; i < m; i++){
      scanf("%d%d",&left,&right);
      if(right < left) swap(left,right);
      int temp = dis[right - 1] - dis[left - 1];
      printf("%d\n",min(temp,sum - temp));
  } 
  return 0;
}

 

posted @ 2018-03-07 20:35  王清河  阅读(96)  评论(0编辑  收藏  举报