11-散列2 Hashing (25 分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize( where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize  (10​^4​​)and N(MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -
复制代码
#include<cstdio>
const int maxn = 10010;

int hashTable[maxn] = {0};

bool isPrime(int n)
{
    if (n <= 1) return false;
    for (int i = 2; i * i <= n; i++)
    {
        if (n % i == 0)
        {
            return false;
        }
    }
    return true;
}

int main()
{
    int n,m;
    scanf("%d%d", &m, &n);
    
    while(!isPrime(m))
    {
        m++;
    }
    
    int pos, temp;
    for (int i = 0 ; i < n; i++)
    {
        scanf("%d",&temp);
        pos = temp % m;
        if (!hashTable[pos])
        {
            hashTable[pos] = 1;
            printf("%d", pos);
        }
        else
        {
            int step = 1;
            for (; step <= m; step++)
            {
                pos = (temp + step * step) % m; 
                if (!hashTable[pos])
                {
                    hashTable[pos] = 1;
                    printf("%d", pos);
                    break;
                }
            }
            if (step >= m)
            {
                printf("-");
            }
        }
        
        if (i < n - 1)
        {
            printf(" ");
        }
    }
    
    return 0;
}
复制代码

 

posted @   王清河  阅读(245)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
历史上的今天:
2018-11-30 KMP 串的模式匹配 (25 分)
2018-11-30 11-散列4 Hashing - Hard Version (30 分)
点击右上角即可分享
微信分享提示