02-线性结构4 Pop Sequence (25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO
复制代码
#include<iostream>
#include<stack>
using namespace std;

const int maxn = 1010;

int check(int *a,int n,int m);

int main()
{
    int arr[maxn] = {0};
    int n,m,k;
    scanf("%d%d%d",&m,&n,&k);
    
    for (int i = 0; i < k; i++)
    {
        for (int j = 1; j <= n; j++)
        {
            scanf("%d",&arr[j]);
        }
        if(check(arr,n,m))
        {
            printf("YES\n");
        }
        else
        {
            printf("NO\n");
        }
    }
    return 0;
}

int check(int *a,int n,int m)
{
    int iRet = -1;
    stack<int> s;
    int current = 1;
    bool flag = true;
    for (int i = 1; i <= n; i++)
    {
        s.push(i);
        if (s.size() > m)
        {
            flag = false;
            break;
        }        
        while (!s.empty() && a[current] == s.top())
        {
            current++;
            s.pop();
        }
    }
    
    if (flag && s.empty())
    {
        iRet = 1;
    }
    else
    {
        iRet = 0;
    }
    
    return iRet;
}
复制代码

 

posted @   王清河  阅读(145)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示