09-排序2 Insert or Merge (25 分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6
 
作者: 陈越
单位: 浙江大学
时间限制: 400 ms
内存限制: 64 MB

 

复制代码
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 110;

int tempOri[maxn],Origin[maxn],changed[maxn];
int n;

bool isSame(int A[],int B[]);
bool Insertion();
void showArray(int A[]);
void HeapSort();
void downAdjust(int low,int high);

int main(){
    scanf("%d",&n);
    for(int i = 0; i < n; i++){
        scanf("%d",&Origin[i]);
        tempOri[i] = Origin[i];
    }
    for(int i = 0; i < n; i++){
        scanf("%d",&changed[i]);
    }
    if(Insertion()){
        printf("Insertion Sort\n");
        showArray(tempOri); 
    }else{
        printf("Heap Sort\n");
        for(int i = 0; i < n; i++){
            tempOri[i] = Origin[i];
        }
        HeapSort();
    }
    return 0;
}

bool Insertion(){
    bool flag = false;
    for(int i = 1;  i < n; i++){
        if(i != 1 && isSame(tempOri,changed)){
            flag = true;
        }
        sort(tempOri,tempOri+i+1);
        if(flag == true){
            return true;
        }
    }
    return false;
}

void HeapSort(){
    bool flag = false;
    for(int i = n/2; i >= 0; i--){
        downAdjust(i,n);
    }
    for(int i = n - 1; i > 0; i--){
        if(i != n - 1 && isSame(tempOri,changed)){
            flag = true;
        }
        swap(tempOri[i],tempOri[n]);
        downAdjust(0,i-1);
        if(flag == true){
            showArray(tempOri);
            return;
        }
    }
}

bool isSame(int A[],int B[]){
    for(int i = 0; i < n; i++){
        if(A[i] != B[i]) return false;
    }
    return true;
}

void showArray(int A[]){
    for(int i = 0; i < n; i++){
        printf("%d",A[i]);
        if(i < n - 1) printf(" ");
    }
}

void downAdjust(int low,int high){
    int i = low,j = i * 2;
    while(j <= high){
        if(j < high && tempOri[j] < tempOri[j+1]){
            j += 1;
        }
        if(tempOri[i] < tempOri[j]){
            i = j;
            j *= 2;
        }else{
            break;
        }
    }
}
复制代码

 

posted @   王清河  阅读(386)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示