05-树8 File Transfer (25 分)

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2  

where I stands for inputting a connection between c1 and c2; or

C c1 c2    

where C stands for checking if it is possible to transfer files between c1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." where k is the number of connected components in this network.

Sample Input 1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

Sample Output 1:

no
no
yes
There are 2 components.

Sample Input 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

Sample Output 2:

no
no
yes
yes
The network is connected.
复制代码
#include<cstdio>
const int maxn = 10010;
typedef int ElementType;
typedef int setName;
typedef int setType[maxn];

void Initialization(setType s,int n);
int Find(setType s,ElementType x);
void Input_connection(setType s);
void Check_connection(setType s);
void Check_network(setType s,int n);

int main(){
    int n;
    char in;
    setType s;
    scanf("%d\n",&n);    
    Initialization(s,n);
    do{
        scanf("%c",&in);
        switch(in){
            case 'I':Input_connection(s);break;
            case 'C':Check_connection(s);break;
            case 'S':Check_network(s,n);break;
        }
    }while(in != 'S');
    return 0;
}

void Input_connection(setType s){
    ElementType u,v;
    scanf("%d%d",&u,&v);
    setName root1,root2;
    root1 = Find(s,u-1);
    root2 = Find(s,v-1);
    if(root1 != root2) s[root1] = root2;
}

void Initialization(setType s,int n){
    for(int i = 0; i < n; i++){
        s[i] = -1;
    }
}

void Check_connection(setType s){
    ElementType u,v;
    scanf("%d%d",&u,&v);
    setName root1 = Find(s,u-1);
    setName root2 = Find(s,v-1);
    if(root1 != root2) printf("no\n");
    else printf("yes\n");
}

void Check_network(setType s,int n){
    int cnt = 0;
    for(int i = 0; i < n; i++){
        if(s[i] < 0) cnt++;
    }
    if(cnt == 1) printf("The network is connected.\n");
    else printf("There are %d components.",cnt);
}

int Find(setType s,ElementType x){
    if(s[x] < 0) return x;
    else return s[x] = Find(s,s[x]);
}
复制代码

 

posted @   王清河  阅读(227)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示