02-线性结构3 Reversing Linked List (25 分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤) which is the total number of nodes, and a positive K (≤) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn = 100010;
struct Node{
    int address,data,next;
    int flag;
}node[maxn];

bool cmp(Node a,Node b){
    return a.flag < b.flag;
}

//void print(int i,int k,int n){
//    int j;
//    for(j = i + k - 1; j >= i; j--){
//        printf("%05d %d ",node[j].address,node[j].data);
//        if(j > i){
//            printf("%05d\n",node[j-1].address);
//        }else{
//            if(i+2*k<=n){
//                printf("%05d\n",node[i+2*k].address);
//            }
//        }
//    }
//}

int main(){
    for(int i = 0 ; i < maxn; i++){
        node[i].flag = maxn;
    }
    int n,k,begin;
    scanf("%d%d%d",&begin,&n,&k);
    int address;
    for(int i = 0; i < n; i++){
        scanf("%d",&address);
        scanf("%d%d",&node[address].data,&node[address].next);
        node[address].address = address;
        //node[address].flag = maxn;
    }
    int count = 0,p = begin;
    while(p!=-1){
        node[p].flag = count++;
        p = node[p].next;
    }
    sort(node,node+maxn,cmp);    
    n = count;    
    for(int i = 0; i < n/k; i++){
        for(int j = (i+1)*k-1; j > i*k; j--){
            printf("%05d %d %05d\n",node[j].address,node[j].data,node[j-1].address);
        }
        printf("%05d %d ",node[i*k].address,node[i*k].data);
        if(i < n/k-1) printf("%05d\n",node[(i+2)*k-1].address);
        else{
            if(n%k==0) printf("-1\n");
            else{
                printf("%05d\n",node[(i+1)*k].address);
                for(i = n/k*k; i < n; i++){
                    printf("%05d %d ",node[i].address,node[i].data);
                    if(i < n-1) printf("%05d\n",node[i+1].address);
                    else printf("-1\n");
                }
            }
        }
    }
    
//    if(n == 1){
//        printf("%05d %d -1\n",node[0].address,node[0].data);
//        return 0;
//    }
//    bool flag = true;
//    if(count%k!=0){
//        while(count%k!=0) count--;
//        flag = false;
//    }
//    for(int i = 0; i < count; i += k){
//        print(i,k,count);
//    }
//    
//    if(flag == true){
//        printf("-1\n");
//    }else{
//        printf("%05d\n",node[count].address);
//        for(int i = count; i < n; i++){
//            printf("%05d %d ",node[i].address,node[i].data);
//            if(i < n - 1) printf("%05d\n",node[i+1].address);
//            else printf("-1\n");
//        }
//    }
//    
//    for(int i = 0; i < n; i++){
//        printf("%05d %d\n",node[i].address,node[i].data);
//    }
    return 0;
}

 

posted @ 2019-04-03 18:42  王清河  阅读(981)  评论(0编辑  收藏  举报