01-复杂度2 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N1​​, N2​​, ..., NK​​ }. A continuous subsequence is defined to be { Ni​​, Ni+1​​, ..., Nj​​ } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4
复制代码
#include<cstdio>
const int maxn = 100100;
int a[maxn] = {0};
int dp[maxn] = {0};
int s[maxn] = {0};

int main(){
    int n;
    scanf("%d",&n);
    bool flag = false;
    for(int i = 0; i < n; i++){
        scanf("%d",&a[i]);
        if(a[i] >= 0) flag = true;
    }
    if(!flag){
         printf("0 %d %d",a[0],a[n-1]);
         return 0;
    }
    //scanf("%d",&n);
    dp[0] = a[0];
    for(int i = 1; i < n; i++){
        if(dp[i-1] + a[i] >= a[i]){
            dp[i] = dp[i-1]+a[i];
            s[i] = s[i-1];
        }else{
            dp[i] = a[i];
            s[i] = i;
        }
    }
    int max = dp[0];
    int k = 0;
    for(int i = 1; i < n; i++){
        if(dp[i] > max){
            max = dp[i];
            k = i;
        }
    }
    printf("%d %d %d",max,a[s[k]],a[k]);
    return 0;
}
复制代码

 

posted @   王清河  阅读(602)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示