1149 Dangerous Goods Packaging (25 分)

When shipping goods with containers, we have to be careful not to pack some incompatible goods into the same container, or we might get ourselves in serious trouble. For example, oxidizing agent (氧化剂) must not be packed with flammable liquid (易燃液体), or it can cause explosion.

Now you are given a long list of incompatible goods, and several lists of goods to be shipped. You are supposed to tell if all the goods in a list can be packed into the same container.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: N (104​​), the number of pairs of incompatible goods, and M (100), the number of lists of goods to be shipped.

Then two blocks follow. The first block contains N pairs of incompatible goods, each pair occupies a line; and the second one contains M lists of goods to be shipped, each list occupies a line in the following format:

K G[1] G[2] ... G[K]

where K (1,000) is the number of goods and G[i]'s are the IDs of the goods. To make it simple, each good is represented by a 5-digit ID number. All the numbers in a line are separated by spaces.

Output Specification:

For each shipping list, print in a line Yes if there are no incompatible goods in the list, or No if not.

Sample Input:

6 3
20001 20002
20003 20004
20005 20006
20003 20001
20005 20004
20004 20006
4 00001 20004 00002 20003
5 98823 20002 20003 20006 10010
3 12345 67890 23333

Sample Output:

No
Yes
Yes
 
复制代码
#include<iostream>
#include<vector>
#include<map>
using namespace std;

int main(){
    map<string,vector<string> > m1;
    map<string,int> m2;
    vector<string> v;
    int n,m;
    cin >> n >> m;
    string a,b;
    while(n--){
        cin >> a >> b;
        m1[a].push_back(b);
        m1[b].push_back(a);
    }
    int k;
    while(m--){
        cin >> k;
        m2.clear();
        v.clear();
        bool flag = 0;
        while(k--){
            cin >> a;
            v.push_back(a);
            m2[a] = 1;
        }
        for(int i = 0; i < v.size(); i++){
            for(int j = 0; j < m1[v[i]].size(); j++){
                if(m2[m1[v[i]][j]] == 1){
                    flag = 1;
                    break;
                }
            }
        }
        if(flag) cout << "No" <<endl;
        else cout << "Yes" <<endl;
    }
    return 0;
}
复制代码

 

posted @   王清河  阅读(426)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示