1112 Stucked Keyboard (20 分)

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:

Each input file contains one test case. For each case, the 1st line gives a positive integer k (1) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:

For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei
case1__this_isss_a_teest
复制代码
#include<cstdio>
#include<cstring>
const int maxn = 1010;
const int maxm = 130;
int k,len,isStuck[maxn] = {0};
char str[maxn];

void judgeStuck(){
    int i = 0, j = 0;
    while(i < len){
        while(j < len && str[j] == str[i]){
            j++;
        }
        if((j - i) % k != 0){
            isStuck[str[i]] = 1;
        }
        i = j;
    }
}

int main(){
    scanf("%d%s",&k,str);
    len = strlen(str);
    judgeStuck();
    for(int i = 0; i < len; i++){
        if(isStuck[str[i]] == 0){
            printf("%c",str[i]);
            isStuck[str[i]] = -1;
        }
    }
    printf("\n");
    for(int i = 0; i < len;){
        printf("%c",str[i]);
        if(isStuck[str[i]] == -1){
            i += k;
        }else{
            i++;
        }
    }
    return 0;
}
复制代码

 

posted @   王清河  阅读(402)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示