POJ 2785 - 4 Values whose Sum is 0(折半枚举)
4 Values whose Sum is 0
Time Limit: 15000MS | Memory Limit: 228000K |
Case Time Limit: 5000MS |
Description
The SUM problemcan be formulated as follows: given four lists A, B, C, D of integer values,compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D aresuch that a + b + c + d = 0 . In the following, we assume that all lists havethe same size n .
Input
The first line ofthe input file contains the size of the lists n (this value can be as large as4000). We then have n lines containing four integer values (with absolute valueas large as 228 ) that belong respectively to A, B, C and D .
Output
For each inputfile, your program has to write the number quadruplets whose sum is zero.
Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output
5
Hint
SampleExplanation: Indeed, the sum of the five following quadruplets is zero: (-45,-27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32,-54, 56, 30).
【题意】
给定各有n个整数的四个数列A,B,C,D。要从每个数列中各取出一个数,使得四个数字和为零。求出这样的组合的个数。当一个数列中有多个相同的数字时,把它们当作不同的数字看待。
1<=n<=4000
|序列中的数字|<=2^28
【思路】
直接用四重循环枚举复杂度是O(n^4)不可行。所以这里用到了折半枚举的思想,先枚举前面两个数组的和的所有可能项,并存入数组中,排序,那么再去逐个枚举后面两个数组的和的可能项,假如从后两个数组中取出来c,d,判断数组中是否有一项x==-(c+d)即可,可以利用二分搜索使复杂度降为O(n^2*logn)。
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
const int maxn = 4050;
int n;
int a[maxn], b[maxn], c[maxn], d[maxn];
int flip[maxn*maxn];
int main() {
while (scanf("%d", &n) == 1) {
for (int i = 0; i < n; i++) {
scanf("%d%d%d%d", &a[i], &b[i], &c[i], &d[i]);
}
for (int i = 0; i < n; i++) {
for (int j = 0; j < n; j++)
flip[i * n + j] = a[i] + b[j];
}
sort(flip, flip + n*n);
ll ans = 0;
for (int i = 0; i < n; i++) {
for (int j = 0; j < n; j++) {
int sum = -(c[i] + d[j]);
ans += upper_bound(flip, flip + n*n, sum) - lower_bound(flip,
flip + n*n, sum);
}
}
printf("%lld\n", ans);
}
return 0;
}