poj 3041 Asteroids(二分图)

Asteroids
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9777   Accepted: 5247

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.


OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
 
二分图最小点覆盖数
选了一个点就相当于覆盖了以它为端点的所有的边,要覆盖所有的边至少需要几个点?
典型的匈牙利算法
做这类题最重要的就是建模
代码很简单,可以留着当模版用
 
#include <iostream>
using namespace std;

const int N=510;
int map[N][N];
int mark[N];
int father[N];
int n, k;

bool dfs(int a)
{
    for(int i=1; i<=n ; i++)
    {
        if(map[a][i]&&!mark[i])
        {
            mark[i]=1;
            if(father[i]==0||dfs(father[i]))
            {
                father[i]=a;
                return true ;
            }
        }
    }
    return false ;
}

int hungary()
{
    int ret=0;
    memset(father , 0 , sizeof(father));
    for(int i=1; i<=n; i++)
    {
        memset(mark, 0, sizeof(mark));
        if(dfs(i))
            ret++;
    }
    return ret;
}

int main()
{
    freopen("e:\\data.txt", "r", stdin);   
    freopen("e:\\out.txt", "w", stdout);
    while(cin>>n>>k)
    {
        memset(map, 0, sizeof(map));
        while(k--)
        {
            int a, b;
            cin>>a>>b;
            map[a][b]=1;
        }
        cout<<hungary()<<endl;
    }
    return 0;
}

 

posted @ 2012-06-05 20:49  w0w0  阅读(179)  评论(0编辑  收藏  举报