poj 2075 Tangled in Cables

Tangled in Cables
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 4464   Accepted: 1831

Description

You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start your business properly and are relying on parts you have found in an old warehouse you bought. Among your finds is a single spool of cable and a lot of connectors. You want to figure out whether you have enough cable to connect every house in town. You have a map of town with the distances for all the paths you may use to run your cable between the houses. You want to calculate the shortest length of cable you must have to connect all of the houses together.

Input

Only one town will be given in an input.
  • The first line gives the length of cable on the spool as a real number.
  • The second line contains the number of houses, N
  • The next N lines give the name of each house's owner. Each name consists of up to 20 characters {a–z,A–Z,0–9} and contains no whitespace or punctuation.
  • Next line: M, number of paths between houses
  • next M lines in the form

< house name A > < house name B > < distance >
Where the two house names match two different names in the list above and the distance is a positive real number. There will not be two paths between the same pair of houses.

Output

The output will consist of a single line. If there is not enough cable to connect all of the houses in the town, output
Not enough cable
If there is enough cable, then output
Need < X > miles of cable
Print X to the nearest tenth of a mile (0.1).

Sample Input

100.0
4
Jones
Smiths
Howards
Wangs
5
Jones Smiths 2.0
Jones Howards 4.2
Jones Wangs 6.7
Howards Wangs 4.0
Smiths Wangs 10.0

Sample Output

Need 10.2 miles of cable

第一次写prim算法 还是费了一番周折的 还好最后是搞出来了~~
还要注意和最大值之间的比较
另外按行扫的时候不要把数组下标搞错了
别的没啥难度
#include<iostream>
#include<string>
using namespace std;

double map[400][400];
double d[400];
int mark[400];
double sum;
int n;

double prim()
{
    double mini;
    int pos;
    int i, j;
    
    sum = 0;
    for(i = 0; i < n; i++)
    {
        d[i] = map[0][i];
    }
    mark[0] = 1;
    d[0] = 0;
    pos = 0;
    for(i = 0; i < n - 1; i++)
    {
        mini = INT_MAX;
        for(j = 0; j < n; j++)
        {
            if(d[j] < mini && mark[j] != 1 && d[j] < INT_MAX)
            {
                pos = j;
                mini = d[j];
            }
        }
        mark[pos] = 1;
        sum += mini;
        for(j = 0; j < n; j++)
        {
            if(map[pos][j] < INT_MAX && d[j] > map[pos][j] && mark[j] != 1)
                d[j] = map[pos][j];
        }
    }
    return sum;
}

int main()
{
    double len;
    double l;
    int m;
    int i, j;
    int col, row;
    string names[400];
    string a, b;
    
    freopen("e:\\data.txt", "r", stdin);   
//    freopen("e:\\out.txt", "w", stdout);
        
    cin>>len;
    cin>>n;
    for(i = 0; i < n; i++)
    {
        for(j = 0; j < n; j++)
            map[i][j] = INT_MAX;
    }
    for(i = 0; i < n; i++)
        d[i] = INT_MAX;
    memset(mark, 0, sizeof(mark));
    
    for(i = 0; i < n; i++)
    {
        cin>>names[i];
    }
    cin>>m;
        
    for(i = 0; i < m; i++)
    {
        cin>>a>>b;
        cin>>l;
        for(j = 0; j < n; j++)
        {
            if(names[j] == a)
            {
                col = j;
            }
            if(names[j] == b)
            {
                row = j;
            }
        }
        map[row][col] = l;
        map[col][row] = l;
    }

    double total = prim();
    if(total > len)         
        cout<<"Not enough cable"<<endl;     
    else        
        cout<<"Need "<<total<<" miles of cable"<<endl;
    return 0;
}

 

posted @ 2012-05-09 21:50  w0w0  阅读(206)  评论(0编辑  收藏  举报