poj 2485 Highways

Highways
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15200   Accepted: 7077

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed.
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

Hint

Huge input,scanf is recommended.
 
#include<iostream>
#include<algorithm>
using namespace std;
#define MAX 510

typedef struct
{
    int x, y;
    int w;
}edge;

int map[MAX][MAX];
edge e[MAX * MAX];
int father[MAX];
int mmax;
 
int cmp(edge a, edge b)
{
    return a.w < b.w;
}
 
void Make_Set(int x)
{
    father[x] = x;
}
 
int Find_Set(int x)
{
    if (x != father[x])
    {
        father[x] = Find_Set(father[x]);
    }
    return father[x];
}

void Union(int x, int y, int w)
{
    father[y] = x;
    if (w > mmax) mmax = w;
}
 
int main()
{
    int i, j, n, k, t;
    freopen("e:\\data.txt", "r", stdin);   
    freopen("e:\\out.txt", "w", stdout);
    cin>>t;
 
    while (t--)
    {
        k = 0;
        mmax = 0;
 
        cin>>n;
 
        for (i = 0; i < n; i++)
        {
            Make_Set(i);
            for (j = 0; j < n; j++)
            {
                cin>>map[i][j];
            }
        }
        for(i = 0; i < n; i++)
        {
            for(j = i + 1; j < n; j++)
            {
                if(i < j)
                {
                    e[k].x = i;
                    e[k].y = j;
                    e[k].w = map[i][j];
                    k++;
                }
            }
        }
        sort(e, e+k, cmp);
 
        for (i = 0; i < k; i++)
        {
            int p, q;
            p = Find_Set(e[i].x);
            q = Find_Set(e[i].y);
            if(p!=q)
                Union(p, q, e[i].w);
        }
 
        cout<<mmax<<endl;
    }
    return 0;
}

 

经典的kruskal算法求最小生成树

本题是要求最小生成树的最大边

第一次写图论的算法还是有点小折腾的,还参考了别人的代码,接着练吧

posted @ 2012-05-09 10:27  w0w0  阅读(156)  评论(0编辑  收藏  举报