poj 2225 Asteroids!

Asteroids!
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2413   Accepted: 919

Description

You're in space.
You want to get home.
There are asteroids.
You don't want to hit them.

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:
  1. Start line - A single line, "START N", where 1 <= N <= 10.
  2. Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:
        'O' - (the letter "oh") Empty space

      'X' - (upper-case) Asteroid present
  3. Starting Position - A single line, "A B C", denoting the [A,B,C] coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.
  4. Target Position - A single line, "D E F", denoting the [D,E,F] coordinates of your target's position. The coordinate values will be integers separated by individual spaces.
  5. End line - A single line, "END"

The origin of the coordinate system is [0,0,0]. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.
The second coordinate in a set indicates the row. Top row = 0.
The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.

Output

For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.

Sample Input

START 1
O
0 0 0
0 0 0
END
START 3
XXX
XXX
XXX
OOO
OOO
OOO
XXX
XXX
XXX
0 0 1
2 2 1
END
START 5
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
XXXXX
XXXXX
XXXXX
XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END

Sample Output

1 0
3 4
NO ROUTE

#include<iostream>
#include<queue>
using namespace std;

struct node
{
    int x, y, z;
};

int n;
queue<node> q;
char map[15][15][15];
int step[15][15][15];

int movex[] = {1, -1, 0, 0, 0, 0};
int movey[] = {0, 0, 1, -1, 0, 0};
int movez[] = {0, 0, 0, 0, 1, -1};

int judge(int ax, int bx, int cx)
{
    if(ax<0 || bx<0 || cx<0 || ax>=n || bx>=n || cx>=n || map[ax][bx][cx] == 'X')
        return 0;
    return 1;    
}

int main()
{
    int i, j, k;
    char temp[10];
    freopen("e:\\data.txt", "r", stdin);   
    freopen("e:\\out.txt", "w", stdout); 
    while(cin>>temp>>n)
    {
        while(!q.empty())
        {
            q.pop();
        }
        memset(map, 0, sizeof(map));
        memset(step, 0, sizeof(step));
        node start, end;
        for(i = 0; i < n; ++i)
        {
            for(j = 0; j < n; ++j)
            {
                for(k = 0; k < n; ++k)
                {
                    cin>>map[i][j][k];   
                }    
            }
        }
        cin>>start.z>>start.y>>start.x;
        cin>>end.z>>end.y>>end.x; 
        if(start.z==end.z&&start.y==end.y&&start.x==end.x)
        {
            cout<<n<<" 0"<<endl;
            cin>>temp;
            continue;
        }
        q.push(start);
        step[start.x][start.y][start.z] = 0;
        while(!q.empty())
        {
            node n = q.front();
            q.pop();
                
            if(n.x == end.x && n.y == end.y && n.z == end.z)
            {
                break;
            }
                
            node next;
            for(i = 0; i < 6; ++i)
            {
                int ax = n.x+movex[i];
                int bx = n.y+movey[i];
                int cx = n.z+movez[i];
                if(judge(ax, bx, cx))
                {
                    map[ax][bx][cx] = 'X';
                    step[ax][bx][cx] = step[n.x][n.y][n.z]+1;
                    next.x = ax;
                    next.y = bx;
                    next.z = cx;
                    q.push(next);
                }
            }
        }
        if(step[end.x][end.y][end.z] == 0)
            cout<<"NO ROUTE"<<endl;
        else
            cout <<n<<" "<<step[end.x][end.y][end.z]<<endl;
        cin>>temp;
    }
    return 0;
}

 

还是三维BFS的题目,本身不难,但是输入很坑爹。。

在输入起点和终点的位置时把坐标顺序换了一下,导致一直wa,要不是看discuss还不知道是这种问题呢o(╯□╰)o

 

posted @ 2012-05-07 23:37  w0w0  阅读(310)  评论(0编辑  收藏  举报