poj 2153 Rank List

Rank List
Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 7563   Accepted: 2440

Description

Li Ming is a good student. He always asks the teacher about his rank in his class after every exam, which makes the teacher very tired. So the teacher gives him the scores of all the student in his class and asked him to get his rank by himself. However, he has so many classmates, and he can’t know his rank easily. So he tends to you for help, can you help him?

Input

The first line of the input contains an integer N (1 <= N <= 10000), which represents the number of student in Li Ming’s class. Then come N lines. Each line contains a name, which has no more than 30 letters. These names represent all the students in Li Ming’s class and you can assume that the names are different from each other.

In (N+2)-th line, you'll get an integer M (1 <= M <= 50), which represents the number of exams. The following M parts each represent an exam. Each exam has N lines. In each line, there is a positive integer S, which is no more then 100, and a name P, which must occur in the name list described above. It means that in this exam student P gains S scores. It’s confirmed that all the names in the name list will appear in an exam.

Output

The output contains M lines. In the i-th line, you should give the rank of Li Ming after the i-th exam. The rank is decided by the total scores. If Li Ming has the same score with others, he will always in front of others in the rank list.

Sample Input

3
Li Ming
A
B
2
49 Li Ming
49 A
48 B
80 A
85 B
83 Li Ming

Sample Output

1
2
#include<iostream>  
#include<stdio.h>
#include<map>
#include<string>
using namespace std;
int sc;
int main()
{
int n, i, j, m, mi, r;
char name[35];
string s;
// freopen("E:\\c++\\oj\\t.txt","rt",stdin);
cin>>n;
map<string, int>namemap;
for(i=0; i<n; i++) {
getchar();
gets(name);
s=name;
namemap[s]=0;
}
cin>>m;
for(i=0; i<m; i++)
{
for(j=0; j<n; j++)
{
scanf("%d ", &sc);
gets(name);
s=name;
namemap[s]+=sc;
}
r=1;
map<string, int>::iterator it;
s="Li Ming";
for(it=namemap.begin(); it!=namemap.end(); it++)
{
if(it->second > namemap[s])
r++;
}
cout<<r<<endl;
}
return 0;
}

posted @ 2011-12-11 08:55  w0w0  阅读(168)  评论(0编辑  收藏  举报