poj 1050 To the Max

To the Max
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 29575   Accepted: 15337

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15
#include<iostream>
using namespace std;
int rec[101][101];
int main()
{
int nums;
int result[101];
// freopen("E:\\c++\\oj\\t.txt","rt",stdin);
cin>>nums;
int m=0;
for(int i=0;i<nums;i++)
{
for(int j=0;j<nums;j++)
{
cin>>rec[i][j];
}
}
for(int i=0;i<nums;i++)
{
memset(result,0,sizeof(result));
for(int j=i;j<nums;j++)
{
int b = 0;
for(int k=0;k<=nums;k++)
{
result[k]+=rec[j][k];
if(b<=0)
b = result[k];
else
b +=result[k];
if(b>m)
m=b;
}
}
}
cout<<m<<endl;
return 0;
}

posted @ 2011-12-10 00:20  w0w0  阅读(166)  评论(0编辑  收藏  举报