poj 3630 Phone List

Phone List
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13726   Accepted: 4408

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES
#include <iostream>
#define MAX_N 120000
using namespace std;

int trieTree[MAX_N + 1][12]; //第10位是ID,第11位是count
int countv = 0;

bool insert(char phone[], int id)
{
int curNode = 0, i, next;
char c;
for(i = 0; i < strlen(phone); i++)
{
c = phone[i];
trieTree[curNode][11]++;
next = trieTree[curNode][c - '0'];
if(next == 0)
trieTree[curNode][c- '0'] = next = ++countv;
curNode = next;
if(trieTree[curNode][10] != 0)
return false;
}
if(trieTree[curNode][11] > 0)
return false;
trieTree[curNode][10] = id;
return true;
}
int main()
{
int caseNum, c, i, pNum;
char temp[10];
scanf("%d", &caseNum);
for(c = 0; c < caseNum; c++)
{
memset(trieTree, 0, sizeof(trieTree));
countv = 0;
scanf("%d", &pNum);
bool can = true;
for(i = 0; i < pNum; i++)
{
scanf("%s", temp);
if(can)
if(!insert(temp, i + 1))
can = false;
}
if(can)
printf("YES\n");
else
printf("NO\n");

}
return 0;
}

posted @ 2011-11-23 10:22  w0w0  阅读(221)  评论(0编辑  收藏  举报