poj 3444 Wavelet Compression

Wavelet Compression
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 1942   Accepted: 1268

Description

The discrete wavelet transform is a popular tool for signal compression. In this problem, your job is to write a program to decompress a one-dimensional signal (a list of integers) that has been compressed by a simple wavelet transform.

To understand how this simple wavelet transform works, suppose that we have a list of an even number of integers. We compute the sum and difference of each pair of consecutive samples, resulting in two lists of sums and differences each having half the original length. Formally, if the original samples are

a(1),..., a(n)

the i-th sum s(i) and difference d(i)are computed as:

for i = 1,...,n/2:

s(i) = a(2*i-1) + a(2*i)
d(i) = a(2*i-1) - a(2*i)

This is then rearranged to give the transformed signal by first listing the sums and then the differences. For example, if the input signal is:

  5, 2, 3, 2, 5, 7, 9, 6

Then the sum and difference signals are:

   s(i) = 7, 5, 12, 15

d(i) = 3, 1, -2, 3

Thus, the transformed signal is:

  7, 5, 12, 15, 3, 1, -2, 3

 

The same process is applied recursively to the first half of the transformed signal, treating s(i)as the input signal, until the length of the input signal is 1. In the example above, the final transformed signal is:

   39, -15, 2, -3, 3, 1, -2, 3

It is assumed that the length of the original input is a power of 2, and the input signal consists of integers between 0 and 255 (inclusive) only.

 

Input

The input consists of a number of cases. Each case is specified on a line, starting with an integer N (1 <= N <= 256) indicating the number of samples. The next N integers are the transformed samples. The end of input is indicated by a case in which N = 0.

Output

For each test case, output the original samples on a single line, separated by a single space.

Sample Input

8 39 -15 2 -3 3 1 -2 3
4 10 -4 -1 -1
0

Sample Output

5 2 3 2 5 7 9 6
1 2 3 4
#include<iostream>
using namespace std;
int res[300];
void process(int a[],int n,int len)
{
int i,j;
int x1,x2;
j=0;
for(i=0;i<len/2;i++)
{
x1=a[i];
x2=a[i+len/2];
res[j]=(x1+x2)/2;
res[j+1]=(x1-x2)/2;
j+=2;
}
for(i=0;i<len;i++)
a[i]=res[i];
if(len==n)
return;
else
process(a,n,len*2);
}
int main()
{
int n;
int i;
int num[300];
while(1)
{
cin>>n;
if(n==0)
break;
for(i=0;i<n;i++)
cin>>num[i];
if(n==1)
{
cout<<num[0]<<endl;
continue;
}
process(num,n,2);
for(i=0;i<n;i++)
{
if(i<n-1)
cout<<num[i]<<"";
else
cout<<num[i];
}
cout<<endl;
}
return 0;
}

posted @ 2011-11-23 10:10  w0w0  阅读(321)  评论(0编辑  收藏  举报