poj 2602 Superlong sums

Superlong sums
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 20143   Accepted: 5835

Description

The creators of a new programming language D++ have found out that whatever limit for SuperLongInt type they make, sometimes programmers need to operate even larger numbers. A limit of 1000 digits is so small... You have to find the sum of two numbers with maximal size of 1.000.000 digits.

Input

The first line of an input file contains a single number N (1<=N<=1000000) - the length of the integers (in order to make their lengths equal, some leading zeroes can be added). It is followed by these integers written in columns. That is, the next N lines contain two digits each, divided by a space. Each of the two given integers is not less than 1, and the length of their sum does not exceed N.

Output

Output file should contain exactly N digits in a single line representing the sum of these two integers.

Sample Input

4
0 4
4 2
6 8
3 7

Sample Output

4750

Hint

Huge input,scanf is recommended.
#include <iostream>
using namespace std;
char str1[1000005],str2[1000005];
int main()
{
int n,i;
scanf("%d ",&n);
for(i=0;i<n;i++)
{
str1[i]=getchar();getchar();
str2[i]=getchar();getchar();
}
for(i=n-1;i>=0;i--)
{
str1[i]+=str2[i]-48;
if(str1[i]>57)
str1[i]-=10,str1[i-1]++;
}
puts(str1);
return 0;
}
posted @ 2011-11-22 12:52  w0w0  阅读(198)  评论(0编辑  收藏  举报