poj 2015 IP Address

IP Address
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 15331   Accepted: 8772

Description

Suppose you are reading byte streams from any device, representing IP addresses. Your task is to convert a 32 characters long sequence of '1s' and '0s' (bits) to a dotted decimal format. A dotted decimal format for an IP address is form by grouping 8 bits at a time and converting the binary representation to decimal representation. Any 8 bits is a valid part of an IP address. To convert binary numbers to decimal numbers remember that both are positional numerical systems, where the first 8 positions of the binary systems are:
2
7
   2
6
  2
5
  2
4
  2
3
   2
2
  2
1
  2
0
 

128 64 32 16 8 4 2 1

Input

The input will have a number N (1<=N<=9) in its first line representing the number of streams to convert. N lines will follow.

Output

The output must have N lines with a doted decimal IP address. A dotted decimal IP address is formed by grouping 8 bit at the time and converting the binary representation to decimal representation.

Sample Input

4
00000000000000000000000000000000 
00000011100000001111111111111111 
11001011100001001110010110000000 
01010000000100000000000000000001 

Sample Output

0.0.0.0
3.128.255.255
203.132.229.128
80.16.0.1
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
char input[9][33];
int output[9][4];
int n;
int sum;
int i,j,k;
int count;
cin>>n;
for(i=0;i<n;i++)
cin>>input[i];
for(i=0;i<n;i++)
{
sum=0;
k=0;
count=128;
for(j=0;j<8;j++)
{
sum+=count*(input[i][j]-'0');
output[i][k]=sum;
count/=2;
}
k++;
sum=0;
count=128;
for(j=8;j<16;j++)
{
sum+=count*(input[i][j]-'0');
output[i][k]=sum;
count/=2;
}
k++;
sum=0;
count=128;
for(j=16;j<24;j++)
{
sum+=count*(input[i][j]-'0');
output[i][k]=sum;
count/=2;
}
k++;
sum=0;
count=128;
for(j=24;j<32;j++)
{
sum+=count*(input[i][j]-'0');
output[i][k]=sum;
count/=2;
}
}
for(i=0;i<n;i++)
{
for(j=0;j<4;j++)
{
if(j<3)
cout<<output[i][j]<<".";
else
cout<<output[i][j];
}
cout<<endl;
}
return 0;
}

posted @ 2011-11-21 23:39  w0w0  阅读(212)  评论(0编辑  收藏  举报