poj 1455 Crazy tea party

Crazy tea party

Time Limit: 1000MS
Memory Limit: 10000K

Total Submissions: 6220
Accepted: 4180

Description

n participants of << crazy tea party >> sit around the table. Each minute one pair of neighbors can change their places. Find the minimum time (in minutes) required for all participants to sit in reverse order (so that left neighbors would become right, and right - left).

Input

The first line is the amount of tests. Each next line contains one integer n (1 <= n <= 32767) - the amount of crazy tea participants.

Output

For each number n of participants to crazy tea party print on the standard output, on a separate line, the minimum time required for all participants to sit in reverse order.

Sample Input

3
4
5
6

Sample Output

2
4
6

 

#include <iostream>
using namespace std;
int main()
{
	int n;
	int m,s;
	cin>>n; 
	while(n--)
	{
		cin>>m;
		if(m%2==0)      
			s=m*(m-2)/4;
		else            
			s=(m-1)*(m-1)/4;
		cout<<s<<endl;                
	}
	return 0;       
}
posted @ 2011-11-21 16:50  w0w0  阅读(141)  评论(0编辑  收藏  举报