poj 1326 Mileage Bank

Mileage Bank
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 11515   Accepted: 4779

Description

Mileage program of ACM (Airline of Charming Merlion) is really nice for the travelers flying frequently. Once you complete a flight with ACM, you can earn ACMPerk miles in your ACM Mileage Bank depended on mileage you actual fly. In addition, you can use the ACMPerk mileage in your Mileage Bank to exchange free flight ticket of ACM in future.



The following table helps you calculate how many ACMPerk miles you can earn when you fly on ACM.

When you fly ACM Class Code You'll earn

First Class F Actual mileage + 100% mileage Bonus

Business Class B Actual mileage + 50% mileage Bonus

Economy Class Y
1-500 miles 500 miles
500+ miles Actual mileage

It's shown that your ACMPerk mileage consists of two parts. One is your actual flight mileage (the minimum ACMPerk mileage for Economy Class for one flight is 500 miles), the other is the mileage bonus (its accuracy is up to 1 mile) when you fly in Business Class and First Class. For example, you can earn 1329 ACMPerk miles, 1994 ACMPerk miles and 2658 ACMPerk miles for Y, B or F class respectively for the fly from Beijing to Tokyo (the actual mileage between Beijing and Tokyo is 1329 miles). When you fly from Shanghai to Wuhan, you can earn ACMPerk 500 miles for economy class and ACMPerk 650 miles for business class (the actual mileage between Shanghai and Wuhan is 433 miles).



Your task is to help ACM build a program for automatic calculation of ACMPerk mileage.

Input

The input file contains several data cases. Each case has many flight records, each per line. The flight record is in the following format:

OriginalCity DistanceCity ActualMiles ClassCode

Each case ends with a line of one zero.

A line of one # presents the end of the input file.

Output

Output the summary of ACMPerk mileages for each test case, one per line.

Sample Input

Beijing Tokyo 1329 F
Shanghai Wuhan 433 Y
0
#

Sample Output

3158
#include<iostream>
using namespace std;
int main()
{
char dst1[100],dst2[100];
int len;
char mark;
int sum;
// freopen("E:\\c++\\oj\\t.txt","rt",stdin);
while(1)
{
cin>>dst1;
sum=0;
if(strcmp(dst1,"#")==0)
break;
while(1)
{
if(strcmp(dst1,"0")==0)
break;
cin>>dst2;
cin>>len;
cin>>mark;
if(mark=='F')
sum+=len*2;
if(mark=='B')
sum=sum+len+(len+1)/2;
if(mark=='Y')
{
if(len<=500&&len>=1)
sum+=500;
else
sum+=len;
}
cin>>dst1;
}
cout<<sum<<endl;
}
return 0;
}

posted @ 2011-11-21 11:00  w0w0  阅读(174)  评论(0编辑  收藏  举报