poj1047 Round and Round We Go

Round and Round We Go
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9629   Accepted: 4374

Description

A cyclic number is an integer n digits in length which, when multiplied by any integer from 1 to n, yields a"cycle"of the digits of the original number. That is, if you consider the number after the last digit to "wrap around"back to the first digit, the sequence of digits in both numbers will be the same, though they may start at different positions.For example, the number 142857 is cyclic, as illustrated by the following table:
142857 *1 = 142857
142857 *2 = 285714
142857 *3 = 428571
142857 *4 = 571428
142857 *5 = 714285
142857 *6 = 857142

Input

Write a program which will determine whether or not numbers are cyclic. The input file is a list of integers from 2 to 60 digits in length. (Note that preceding zeros should not be removed, they are considered part of the number and count in determining n. Thus, "01"is a two-digit number, distinct from "1" which is a one-digit number.)

Output

For each input integer, write a line in the output indicating whether or not it is cyclic.

Sample Input

142857
142856
142858
01
0588235294117647

Sample Output

142857 is cyclic
142856 is not cyclic
142858 is not cyclic
01 is not cyclic
0588235294117647 is cyclic
#include<iostream>
#include<algorithm>
using namespace std;
char innum[65];
char res[65];
char temp[65];
void multi(int n,int l)
{
int i,j;
int add;
add=0;
int sum;
for(i=l-1,j=0;i>=0;i--,j++)
{
sum=(temp[i]-'0')*n+add;
add=sum/10;
res[j]=sum%10+'0';
}
}
int comp(char &a,char &b)
{
return a<b;
}
int main()
{

int i;
int len;

while(cin>>innum)
{
strcpy(temp,innum);
len=strlen(innum);
sort(innum,innum+len);
for(i=1;i<=len;i++)
{
multi(i,len);
sort(res,res+strlen(res));
if(strcmp(innum,res)!=0)
break;
}
if(i<=len)
cout<<temp<<" is not cyclic"<<endl;
else
cout<<temp<<" is cyclic"<<endl;
}
return 0;
}

posted @ 2011-11-21 09:22  w0w0  阅读(170)  评论(0编辑  收藏  举报