poj1007 DNA Sorting

DNA Sorting
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 60087   Accepted: 23717

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
#include<iostream>
using namespace std;
int main()
{
int n,m;
int i,j,k;
char data[101][51];
int count[101];
char temp[51];
int temp_count=0;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(i=0;i<m;i++)
cin>>data[i];
for(k=0;k<m;k++)
{
count[k]=0;
for(i=0;i<n;i++)
{
for(j=i;j<n;j++)
{
if(data[k][i]>data[k][j])
count[k]++;
}
}
}
for(i=0;i<m;i++)
{
for(j=0;j<m-i-1;j++)
{
if(count[j]>count[j+1])
{
strcpy(temp,data[j+1]);
strcpy(data[j+1],data[j]);
strcpy(data[j],temp);
temp_count=count[j+1];
count[j+1]=count[j];
count[j]=temp_count;
}
}
}
for(i=0;i<m;i++)
{
cout<<data[i]<<endl;
}
}
return 0;
}

posted @ 2011-11-21 09:11  w0w0  阅读(181)  评论(0编辑  收藏  举报