同余定理

Light OJ---1078

题意: 给你两个整数,n和m,问有最少有几个m组成的数能被n整除。。。。。不用同余会超时。。。。

思路:同余定理:

(A + B) mod M = ( A mod M + B mod M ) mod M
(A * B) mod M = ((A mod M) *( B mod M)) mod M  

Description

If an integer is not divisible by 2 or 5, some multiple of that number in decimal notation is a sequence of only a digit. Now you are given the number and the only allowable digit, you should report the number of digits of such multiple.

For example you have to find a multiple of 3 which contains only 1's. Then the result is 3 because is 111 (3-digit) divisible by 3. Similarly if you are finding some multiple of 7 which contains only 3's then, the result is 6, because 333333 is divisible by 7.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case will contain two integers n (0 < n ≤ 106 and n will not be divisible by 2 or 5) and the allowable digit(1 ≤ digit ≤ 9).

Output

For each case, print the case number and the number of digits of such multiple. If several solutions are there; report the minimum one.

Sample Input

3

3 1

7 3

9901 1

Sample Output

Case 1: 3

Case 2: 6

Case 3: 12

#include <cstdio>
#include <cstring>
#include<iostream>
#include<queue>
#include<stack>
#include<cmath>
#include <map>
#include <algorithm>
using namespace std;
map<string, string>mp;
vector<vector<int> >G;


const int INF=0x3f3f3f3f;
const int maxn=1100;

int main()
{
    int T, cas=1;
    scanf("%d", &T);

    while(T--)
    {
        int n, m;
        scanf("%d %d", &n, &m);
        int t=m%n;

        int ans=1;
        while(t)
        {
            t=(t*10+m)%n;
            ans++;
        }
        printf("Case %d: %d\n", cas++, ans);
    }
    return 0;
}
View Code


 

posted @ 2016-08-01 15:44  爱记录一切美好的微笑  阅读(376)  评论(0编辑  收藏  举报