package com.vow;

/**
 * @author vow
 *
 *每个整数都希望可以整除很多数字,特别是它自身包含的数字,我们将整数分为三类:

1.    数字可以整除它包含的一部分数字,比如72,由,7和2两种数字组成,72可以整除2,我们称这个数字是开心的,用”H”表示。

2.    数字不能整除它包含的任何数字,比如73,由,7和3两种数字组成,73不能整除任何数,我们称这个数字是沮丧的,用”S”表示。

3.    数字可以整除它包含的所有数字,比如12,既可以整除1又可以整除2,我们称它是一个非常棒的数,用“G”表示。

(0可以被任何数整除。)

输入
输入第一行包含一个整数T,表示数据组数(1<=T<=100).

接下来T行,每行包含一个正整数n(1<=n<=10^12),表示需要你判断的数字。

输出
对于每组测试数据输出一行,“H”,“S”或“G”。表示整数种类。


样例输入
3
72
73
12
样例输出
H
S
G
 */
import java.util.*;
public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
    Scanner in=new Scanner(System.in);
    int num=in.nextInt();
    for(int i=0;i<num;i++)
    {
    	 int count1=0;
    	 int count2=0;
    	int n=in.nextInt();
    	int temp=n;
    	if(n>10){
    	while(n>0)
    	{
        int zi=n%10;
         count1++;
        if(temp%zi==0)
    	count2++;
        	n=n/10;

        } 
    	if(count2==0)
    		System.out.println("S");
    	if(count2!=0&&count2<count1)
    		System.out.println("H");
    	if(count1==count2)
    		System.out.println("G");
    	}
    	if(temp<=10)
    		
    		System.out.println("G");
	}
 }
}

 

posted on 2019-04-28 22:18  vow007  阅读(6)  评论(0编辑  收藏  举报  来源