Zipper

Zipper

Given three strings, you are to determine whether the third string can
be formed by combining the characters in the first two strings. The
first two strings can be mixed arbitrarily, but each must stay in its
original order.

For example, consider forming “tcraete” from “cat” and “tree”:

String A: cat String B: tree String C: tcraete

As you can see, we can form the third string by alternating characters
from the two strings. As a second example, consider forming “catrtee”
from “cat” and “tree”:

String A: cat String B: tree String C: catrtee

Finally, notice that it is impossible to form “cttaree” from “cat” and
“tree”.

Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

Output
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
Sample Input
3
cat tree tcraete
cat tree catrtee
cat tree cttaree
Sample Output
Data set 1: yes
Data set 2: yes
Data set 3: no

解题思路:
把s3的每一个字母在s1和s2中寻找,如果匹配,相应下标向后移动,直到下标不再对应字母。

Code:

#include<iostream>
#include<cstring>
using namespace std;
const int maxn = 5e2+5;
int len1,len2,len3,flag=0;
string s1,s2,s3;
int vis[maxn][maxn];
void dfs(int x,int y){
	if(x==len1&&y==len2){
		flag=1;
		return ;
	}
	if(vis[x][y]) return ;
	if(s1[x]==s3[x+y]) dfs(x+1,y);
	if(s2[y]==s3[x+y]) dfs(x,y+1);
	vis[x][y]=1;
}
int main(){
	int t;
	cin>>t;
	int ans=1;
	int dp[maxn][maxn];
	while(t--){
		memset(vis,0,sizeof(vis));
		flag=0;
		cin>>s1>>s2>>s3;
		len1=s1.length();
		len2=s2.length();
		len3=s3.length();
		if(len1+len2!=len3){
			cout<<"no"<<endl;
			return 0;
		}
		dfs(0,0); 
		printf("Data set %d: ",ans++);
		if(flag) cout<<"yes"<<endl;
		else cout<<"no\n";
	}
	
	return 0;
}
posted @ 2019-07-30 22:41  voids5  阅读(167)  评论(0编辑  收藏  举报