HDU 2035-人见人爱A^B(乘方取模)
Time limit
1000 ms
Memory limit
32768 kB
求A^B的最后三位数表示的整数。
说明:A^B的含义是“A的B次方”
Input
输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。
Output
对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。
Sample Input
2 3
12 6
6789 10000
0 0
Sample Output
8
984
1
代码:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
int Mypow(int a,int b)
{
int x = a;
int re = 1;
while(b)
{
if(b&1)
{
re *= x;
re %= 1000;
}
x *= x;
x %= 1000;
b>>=1;
}
return re;
}
int main()
{
int a,b;
while(cin>>a>>b && a && b)
{
printf("%d\n",Mypow(a,b));
}
return 0;
}