HDU 2014 - 青年歌手大奖赛_评委会打分

 参加过上个月月赛的同学一定还记得其中的一个最简单的题目,就是{A}+{B},那个题目求的是两个集合的并集,今天我们这个A-B求的是两个集合的差,就是做集合的减法运算。(当然,大家都知道集合的定义,就是同一个集合中不会有两个相同的元素,这里还是提醒大家一下)

呵呵,很简单吧? 

Input
每组输入数据占1行,每行数据的开始是2个整数n(0<=n<=100)和m(0<=m<=100),分别表示集合A和集合B的元素个数,然后紧跟着n+m个元素,前面n个元素属于集合A,其余的属于集合B. 每个元素为不超出int范围的整数,元素之间有一个空格隔开.
如果n=0并且m=0表示输入的结束,不做处理。
Output
针对每组数据输出一行数据,表示A-B的结果,如果结果为空集合,则输出“NULL”,否则从小到大输出结果,为了简化问题,每个元素后面跟一个空格.
Sample Input

3 3 1 2 3 1 4 7
3 7 2 5 8 2 3 4 5 6 7 8 
0 0

Sample Output

2 3 
NULL

思路:
binary_search的简单应用

代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;

int boardA[105];
int boardB[105];

int main()
{
    int N,M;
    while(scanf("%d %d",&N,&M))
    {
        if(N == 0 && M == 0)break;
        for(int i=0 ; i<N ; i++)
        {
            scanf("%d",&boardA[i]);
        }
        for(int i=0 ; i<M ; i++)
        {
            scanf("%d",&boardB[i]);
        }
        sort(boardB,boardB+M);
        sort(boardA,boardA+N);
        int sum = 1;
        for(int i=0 ; i<N ; i++)
        {
            if(binary_search(boardB,boardB+M,boardA[i]))continue;
            printf("%d ",boardA[i]);
            sum = 0;
        }
        if(sum)printf("NULL\n");
        else printf("\n");
    }
    return 0;
}
posted @ 2017-10-02 22:02  Assassin_poi君  阅读(198)  评论(0编辑  收藏  举报