Nim游戏(Nim入门经典题)
有N堆石子。A B两个人轮流拿,A先拿。每次只能从一堆中取若干个,可将一堆全取走,但不可不取,拿到最后1颗石子的人获胜。假设A B都非常聪明,拿石子的过程中不会出现失误。给出N及每堆石子的数量,问最后谁能赢得比赛。
例如:3堆石子,每堆1颗。A拿1颗,B拿1颗,此时还剩1堆,所以A可以拿到最后1颗石子。
Input
第1行:一个数N,表示有N堆石子。(1 <= N <= 1000)
第2 - N + 1行:N堆石子的数量。(1 <= Ai
<= 10^9)
Output
如果A获胜输出A,如果B获胜输出B。
Sample Input
3
1
1
1
Sample Output
A
代码:
#include <iostream>
#include <cstdio>
using namespace std;
int main(){
int N;
scanf("%d",&N);
int a;
scanf("%d",&a);
while(--N){
int mid;
scanf("%d",&mid);
a ^= mid;
}
if(a)printf("A");
else printf("B");
return 0;
}