1218--THE DRUNK JAILER

THE DRUNK JAILER
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 29494   Accepted: 18165

Description

A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked. 
One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey,and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the 
hall locking every other cell (cells 2, 4, 6, ?). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ?). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He 
repeats this for n rounds, takes a final drink, and passes out. 
Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape. 
Given the number of cells, determine how many prisoners escape jail.

Input

The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n. 

Output

For each line, you must print out the number of prisoners that escape when the prison has n cells. 

Sample Input

2
5
100

Sample Output

2
10
思路:
题目虽然很长,但是就是一个简单的开关门问题。根据题目意思,第10扇门,在第1,2,5,10次会改变状态;第20扇门,在第1,2,4,5,10,20次改变状态,所以我们不难发现,每一扇门改变状态的次数就是该门编号的因数个数,只有最后门开着,犯人才会跑出来。
也就是说,当门的状态改变奇数次,也就是门编号的因数为奇数个时,该门最后是打开的。而因数为奇数的数字只有1,4,9此类数字,也就是1,2,3,···的平方。
代码:
#include<stdio.h>
#include<math.h>
int main()
{
    int n,cell;
    scanf("%d",&n);
    while(n--){
        scanf("%d",&cell);
        if(cell>=5&&cell<=100){
        printf("%d\n",(int)sqrt(cell));    
        }
    }
    return 0;
}

 

posted @ 2019-07-09 21:02  心悦晨晨  阅读(145)  评论(2编辑  收藏  举报