Loading

1008 Elevator (20 分)

1. 题目

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

2. 题意

电梯上升一层需6秒,每层停止5秒,下降一层需4秒,计算电梯在层数之间移动所花费的时间。

3. 思路——简单模拟

根据题意模拟计算即可 。

4. 代码

#include <iostream>

using namespace std;

int main()
{
    int n;
    cin >> n;
    int b = 0;
    int x;
    int sum = 0;
    // 根据题意:电梯上升一层需6秒,每层停止5秒,下降一层需4秒 ,模拟计算即可 
    for (int i = 0; i < n; ++i)
    {
        cin >> x;
        if (x - b > 0) sum += (x - b) * 6 + 5;
        else sum += (b - x) * 4 + 5;
        b = x;
    }
    cout << sum << endl;
    return 0;
}
posted @ 2021-10-28 22:13  August_丶  阅读(36)  评论(0编辑  收藏  举报